09-04-2014

Dear customers! In connection with the "OpenSSL Security Advisory [07 Apr 2014]" we inform you that our service doesn't use OpenSSL which is affected by recently mentioned security weakness.

Be safe with us!